Typo3 Updatet auf Version 4.2

TulpenGerade lese ich auf golem.de etwas von neuer verbesserter Typo3-Version.
Da kann man ja mal ein Update machen, das dauert ja nicht so lange – erst aber schön an das Backup denken.

Dann das tar-File entpacken, den Soft-Link (typo3_src -> typo3_src-4.2.0) im Dateisystem korrigieren und
ein Aufruf der Seite „https://www.perl-online.com/typo3/install/“ sollte mittels ‚3: Update Wizard‚ den Rest tun. – Tat sie sicher auch, allerdings sahen die ersten 10 Aufrufe ziemlich daneben aus. Es gab circa tausend Zeilen mit Fehlermeldungen. Obwohl ich vorher auch die Caches leer gemacht hatte.

Im Typo3-Wiki (Upgrade to 4.2) stand dazu auch nicht viel.

Nach dem zehnten mal Hin und Her (Cache im Typo3 löschen, Cache im Firefox löschen ….) ging dann plötzlich alles wieder wie gehabt – Mysteriös, aber was soll’s. :-)

Mal sehen was die neue Version alles bringt? Ich meine wie sich die Neuerungen anfühlen?: Thoyhyqmasyhyqyhyq Esders“ target=“_blank“>New features in latest release

Jetzt geht übrigens auch die Funktion ‚TER3 auf Updates überprüfen‚ wieder.

von der Kita zur MamaAllerdings ist im Backend jetzt der Seitenbaum plötzlich leer. Mal sehen woran das liegt.
Ein Updaten aller Extensions brachte auch keine Linderung. Also habe ich alle Extensions, die ich nicht brauchte deaktiviert. Auch nicht besser. :-(
Die Webseite ist aber weiterhin da. Im Menü-Punkt ‚Zugriff‘ sieht man auch noch alle Seiten. Also lasse ich jetzt erst mal alles auf Version 4.2.0 und google weiter, ob das Problem woanders auch auftaucht.

Vor dem Update musste ich aber noch unser Heayhyqtheyhyqryhyqyhyq von der Kita holen. Wir sind dann von der Kita zu Mama’s Arbeit geschoben und dann konnte ich mit dem Fahrrad weiter nach Hause fahren.

Uwes Tachodaten

  • Gesamtstrecke: 16,3 km
  • reine Fahrzeit: 0:40:08 h
  • Durchschnitt: 24,9 km/h
  • Maximal: 41,9 km/h
  • Temp.Min: 12°C

Nachtrag:
Heute (nächster Tag) Nachmittag erzählte mir mein Nagios plötzlich, dass die ganze Webseite weg sei. Nach kurzem ins Backend sehen, habe ich jetzt einfach das mysql-Backup wieder zurück gespielt und auch den Softlink typo3_src wieder auf typo3_src-4.1.1 gerichtet und nun geht wieder alles – mit Version 4.1.1. Sowohl die Webseiten im Frontend als auch der Seitenbaum im Backend. Sogar die deaktivierten Plugins sind weiterhin deaktiviert.
Nachtrag zwo:
So ganz glatt ging das Zurück spielen dann aber doch nicht. Erst fiel nur auf, dass ein Großteil der Seiten im Typo3 nicht mehr erreichbar waren. Also habe ich erst mal angefangen mein Typo3 leer-zuziehen.
Dann fand ich aber auch den Auslöser des Problemes: die Tabellen des Plugin ‚tx_realurl‚ sind korrupt:
typo42.tx_realurl_chashcache: Corrupt
typo42.tx_realurl_pathcache: Corrupt
typo42.tx_realurl_urldecodecache: Corrupt

Die restlich Seiten sind jetzt dadurch wieder erreichbar, dass ich das Plugin ‚tx_realurl‚ deaktiviert habe. :-(
Aber ich wollte meine Webseiten ja sowieso mal in ein einheitliches ‚CMS‘ ziehen. Das bisherige Typo3/WordPress-Durcheinander macht auf Dauer ja auch weinig Sinn. Also werde ich die Seiten weiter aus dem Typo3-Bereich ins WordPress übertragen.

Nachtrag drei:
Für das Problem mit dem leeren Seitenbaum und den defekten SQL-Tabellen gibt es auch eine saubere Lösung.:
Im ‚TYPO3 4.2 Install Tool‚ den Punkt ‚2: Database Analyser‚ auswählen und dort dann ‚Update required tables COMPARE‚. Dann noch ein Klick auf ‚Write to Database‚ und es funktioniert wieder alles.
Kleiner Tipp für Leute mit Firefox (wie mich) – der Browsercache zaubert womöglich noch eine Weile die alte Seite mit Fehlermeldung hervor. – Nerv- :-(
Außerdem musste ich alle ’sg_**‘-Pugins deaktivieren (sg_userdata, sg_div …) weil ’sg_div‘ einen Fehler ausgab.

Gelesen: 4556 · heute: 2 · zuletzt: Sat 13.July 2019

One Response to “Typo3 Updatet auf Version 4.2

  • Jau,- super.
    Danke, für Deinen Blog (Nachtrag 3).
    Das war es bei mir auch mit dem Seitenbaum.
    Mictpykhatpyktpyk

Schreibe einen Kommentar

Deine E-Mail-Adresse wird nicht veröffentlicht. Erforderliche Felder sind mit * markiert.